PROCV X PROCX

Bastante gente ficou em dúvida sobre o último post, sobre PROCX.

Vou fazer uma comparação com o clássico PROCV. Segue arquivo aqui.

PROCV:

Digamos que eu tenha a base a seguir.

Quero procurar “LAMINA” e retornar o preço unitário.

Com procv, os parâmetros são:

– o que quero procurar (célula G3)

– a tabela onde quero procurar, onde a coluna a procurar é a primeira (B3:D8)

– quando eu encontrar, qual o número da colunas à direita (terceira coluna).

Com procX:

– o que quero procurar (célula G3)

– a coluna onde quero procurar (B3:B8)

– a coluna do valor encontrado   (D3:D8)

Alguns dos superpoderes abaixo.

Busca à esquerda:

Procv: não retorna coluna à esquerda

Procx: é só mudar a coluna do valor (A3:A8)

=PROCX(G3;B3:B8;A3:A8)

Procura de baixo para cima:

                Procv: O procv sempre busca o primeiro valor de cima para baixo. Não é possível fazer o contrário.

                Procx:  basta colocar -1 no último parâmetro opcional. =PROCX(G3;B3:B8;D3:D8;;;-1)

E se não encontrar?

                Procv: Dá erro

                Procx: é possível estabelecer um valor caso não encontre.  =PROCX(G6;B3:B8;D3:D8;”Não Encontrado”)

Arquivo para download.

Lembrando que o procx só funciona em versões a partir do Office 365.

Veja também:

Ideias técnicas com uma pitada de filosofia https://ideiasesquecidas.com/

Computação e informação quântica: https://informacaoquantica.wordpress.com/

Deixe um comentário

Faça o login usando um destes métodos para comentar:

Logo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s