Intervalos e desloc – solução

Em relação ao post anterior, https://ferramentasexcelvba.wordpress.com/2020/04/08/exercicio-de-intervalos-e-funcao-desloc/

Planilha para download.

A função “corresp” é uma função de busca, similar ao procv. Porém, ela retorna a posição do valor, o índice.

Corresp(valor, range de busca, busca exata ou maior)

Abaixo, corresp da data (06/01/2020) vai retornar 9

Primeira ocorrência (posição)

=CORRESP($H$4;$B$3:$B$206;0) – a busca exata vai dar a primeira ocorrência.

Abaixo, corresp da data (06/01/2020) vai retornar 12

Última ocorrência (posição)

=CORRESP($H$4;$B$3:$B$206;1) – coloquei o parâmetro “1”, então vai buscar o último valor do dia 06/01/2020

Número de transações: pode ser um cont.se, e também pode ser a diferença entre a última ocorrência e a primeira

Primeira ocorrência:  utilizar a função desloc. É como um mapa do tesouro. A partir de um ponto inicial, ande y casas para baixo e x casas para a direita.

=DESLOC($B$2;H11;2)

A referência é a célula B2. Ando para baixo o número de casas da primeira ocorrência. Ando para a direita 2 casas, porque quero buscar o valor.

Primeira ocorrência:  a mesma coisa, usar desloc. Só que ao invés de andar a primeira ocorrência, uso a posição da última ocorrência

=DESLOC($B$2;H12;2)

Para média, mín e máx, o truque é semelhante.

Uso a função =MÉDIA(intervalo)

A questão é definir o intervalo.

Aí, a função desloc ajuda novamente. Ela pode retornar um número, como acima, mas também pode retornar um intervalo.

São 5 parâmetros para o desloc: 1 – ponto de partida, 2 – casas para baixo a deslocar, 3 – casas para direita, 4 – range de linhas do intervalo, 5 – range de colunas do intervalo

O range de linhas é o cont.se da célula H4. O range de colunas é 1.

A fórmula final:

Média =MÉDIA(DESLOC($B$2;$H$11;2;$H$14;1))

Mínimo do dia =MENOR(DESLOC($B$2;$H$11;2;$H$14;1);1)

Máximo do dia =MAIOR(DESLOC($B$2;$H$11;2;$H$14;1);1)

É possível utilizar a função “INDIRETO” para alguns desses cálculos. É a mesma ideia.

Corresp e Desloc são formas indiretas, um pouco mais abstratas, de referenciar dados. É como um ponteiro em C. São um pouco mais avançadas, porém, bastante poderosas.

Ideias técnicas com uma pitada de filosofia

https://ideiasesquecidas.com/

Deixe um comentário

Faça o login usando um destes métodos para comentar:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Foto do Google

Você está comentando utilizando sua conta Google. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s