Exercício de estatística

Temos uma série histórica de dados (digamos, uma medição por mês do consumo).

Responda:

  • Qual a distribuição Normal que melhor fita os dados da Coluna A?
  • Qual a distribuição Uniforme que melhor fita os dados da Coluna A?
  • Desenhe um histograma desta distribuição
  • Qual das duas distribuições (Normal ou Uniforme) fita melhor os dados?

Respostas:

Primeiro, para que serve isto?

Uma aplicação clássica é para forecast, por exemplo. Tenho uma série de dados históricos, e quero prever o comportamento futuro, e tomar ações, digamos, considerar um estoque mínimo para garantir um nível de serviço.

A Normal é a curva em forma de sino. Ela tem dois parâmetros, média e desvio padrão.
=MÉDIA(A2:A94)
=DESVPAD.A(A2:A94)

No fundo, fazer forecast é como se eu tivesse que dar um chute.

Se eu não souber muito bem o comportamento da curva, posso dizer: fica entre 270 e 723.


A uniforme é exatamente isto, ela tem a mesma probabilidade de dar qualquer valor entre mínimo e máximo.
=MÍNIMO($A$2:$A$94)
=MÁXIMO($A$2:$A$94)

Para ilustrar o resultado, fiz mais duas listas. A primeira faz um sorteio baseado numa normal, e a segunda, numa uniforme.



A uniforme é mais fácil de explicar.
É como usar a função aleatório entre (mínimo, máximo).
Porém, ela é discreta, e a versão contínua é a fórmula seguinte.
=ALEATÓRIO()*($F$17-$F$16)+$F$16

Para sortear uma normal, o truque é usar a fórmula inv.normal (inverso da normal acumulada), com um parâmetro aleatório.
=INV.NORM(ALEATÓRIO();$F$11;$F$12)

Fiz o histograma com fórmulas cont.ses. A ideia é contar quantos itens das listas estão entre 250 e 300, 300 e 350, etc…

Nota-se que a normal parece representar melhor os dados que a uniforme, para este caso específico.

A distribuição acumulada é outra forma de ver.

Clicar em F9 para sortear outros valores, e ver a diferença.

Segue arquivo no onedrive.

Estatística não é a área que mais domino, então sugestões e complementações são bem vindas.


Ideias técnicas com uma pitada de filosofia: https://ideiasesquecidas.com

Ferramentas Excel-VBA: https://ferramentasexcelvba.wordpress.com/

Publicidade

Deixe um comentário

Faça o login usando um destes métodos para comentar:

Logo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair /  Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair /  Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair /  Alterar )

Conectando a %s